Jump to content
Sign in to follow this  
Park Life

Mac boys: Summat is blocking port 25

Recommended Posts

Its not just Macs, I had a client with this problem the other week. It turns out that port 25 is often blocked by ISPs these days to stop Spam. It will only affect you however if you use a different SMTP mail server to your ISPs. For instance all of my mail is through my server and not BT Internet.

 

What you need to do is contact your ISP and ask them to open the messages up on port 587, with SMTP authentication enabled.

Share this post


Link to post
Share on other sites
Its not just Macs, I had a client with this problem the other week. It turns out that port 25 is often blocked by ISPs these days to stop Spam. It will only affect you however if you use a different SMTP mail server to your ISPs. For instance all of my mail is through my server and not BT Internet.

 

What you need to do is contact your ISP and ask them to open the messages up on port 587, with SMTP authentication enabled.

 

Didn't call anyone and just went into the e mail settings and changed it over to 587. Seems to be working fine, fingers crossed.

 

Cheers. :calmdown:

Share this post


Link to post
Share on other sites

Ok.

 

Port 587 has been working for a couple of weeks and now that has stopped with some Mac message about SSL certificate not being valid..!! :D

 

 

a) Shall I hoy the thing out the window?

:nah: Calmly go about addressing the issue?

c) Have a joint do it tomorrow?

Share this post


Link to post
Share on other sites

in your SMTP settings try adding novalidate-cert at the end, that could sort it.

 

 

eg if yours currently says something like smtp.mac.com/user=PARKLIFE then make it smtp.mac.com/user=PARKLIFE novalidate-cert

Share this post


Link to post
Share on other sites
in your SMTP settings try adding novalidate-cert at the end, that could sort it.

 

 

eg if yours currently says something like smtp.mac.com/user=PARKLIFE then make it smtp.mac.com/user=PARKLIFE novalidate-cert

 

I've unchecked the smtp box in the e email preferences bit and the mail started working straight away.

 

This will only effect the security of e mails though right and has nowt to do with browsing etc?

 

Thanks for your help btw.

Share this post


Link to post
Share on other sites
in your SMTP settings try adding novalidate-cert at the end, that could sort it.

 

 

eg if yours currently says something like smtp.mac.com/user=PARKLIFE then make it smtp.mac.com/user=PARKLIFE novalidate-cert

 

I've unchecked the smtp box in the e email preferences bit and the mail started working straight away.

 

This will only effect the security of e mails though right and has nowt to do with browsing etc?

 

Thanks for your help btw.

 

yeah turning smtp off will only affect emails (Secure Mail Transfer Protocol)....christ Im a sad arsed fuck!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

Recent tweets

Toontastic Facebook

Donate to Toontastic

Keeping the lights on since... well ages ago
TT-Staff


×